Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Parsel Installation Issue?

BBodien
Minted
Posted on Feb 13, '07 at 05:07 am

I’m having some problems installing Parsel 1.0.2.

First of all the zip doesn’t contain the ‘since1968’ parent folder, so I had to create this manually. The parsel directory in the zip also contains a .svn tree which seems a little odd.

The main problem though is that when I upload it all, and go to my Mint preferences, the prefs page only loads as far as the end of the pane order column, so I can’t see any of the right hand Pepper column. The last bit of code output on the page is Pepper.

Are there any known compatibility issues?

(running mint 2.02)

Sam Brown
Third-Party Pepper Developer
Posted on Feb 13, '07 at 06:02 am

I didn’t bother uploading the .svn files. Simply created the since1968 folder and then created the parsel folder and uploaded the class.php file to that.

No problems here.

/mint/pepper/since1968/parsel/class.php

BBodien
Minted
Posted on Feb 13, '07 at 08:14 am

Thanks for the response, Sam.

Having .svn in there or not doesn’t seem to make a difference. It’s very odd.

Here’s the outcome when I upload

/mint/pepper/since1968/parsel/class.php

screenshot

(you can see the other peppers that I have installed there)

The last bit of code output is:

<h2 class="first-child">Pepper</h2>

So it’s like PHP died while trying to parse the pepper directory or something.

Sam Brown
Third-Party Pepper Developer
Posted on Feb 13, '07 at 10:50 am

This may be Pepper related, not sure what to proceed with in this situation, best wait for a response from Shaun.

Sam Brown
Third-Party Pepper Developer
Posted on Feb 13, '07 at 10:58 am

BBodien, if you delete the since1968 directory (even though you may get errors within Mint does it solve the problem?

BBodien
Minted
Posted on Feb 15, '07 at 10:08 am

Hi Sam,

Yes, without that directory there the prefs page renders fine. Reupload it and the error comes straight back again.

(No errors anywhere in mint since I didn’t even get a chance to install the Parsel pepper yet, so deleting the dir is fine)

I’m wondering if it’s a PHP 4/5 compatibility issue in the code for this pepper - my hosted server is running PHP 4.4.4.

since1968
Third-Party Pepper Developer
Posted on Feb 19, '07 at 08:50 pm

BBodien, I’m the developer for Parsel.

We just had a baby (woo hoo!) and I haven’t had time to look at the forums. Sorry you’re having trouble with Parsel—I’ll check back here in about a week and help you sort out the problem.

You can also email me directly: marc.garrett@gmail.com.

Shaun Inman
Mint/Pepper Developer
Posted on Feb 19, '07 at 09:24 pm

Congrats on the little one Marc!

since1968
Third-Party Pepper Developer
Posted on Feb 22, '07 at 11:21 am

Thank you Shaun.

Any update on this plugin? I’d really like to use it for my internationalization process.

AndrewC
Minted
Posted on Oct 09, '09 at 11:30 pm

I am having this exact same problem. Was a solution ever found? I am using PHP 5.2.6.

You must be logged in to reply. Login above or create an account